Jump to content
  • 0
Sign in to follow this  
Felipe Arruda

Bug no Chat

Question

Boa tarde, galera!

Estou com um bug no chat de grupo, onde todas as mensagens enviadas tem a última letra cortada.

Por Exemplo.: Se eu digito: "Hello World, Ragnarok Online"

Aparece: "Hello World, Ragnarok Onlin"

Não importa o número de letras, sempre corta a última. (apenas no chat de GRUPO e PM)
Isso é alguma coisa na src, Pois o Spell Master já solucionou esse erro mas não compartilhou o mesmo. Peço a ajuda de vocês encarecidamente. 

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Dê uma pesquisada que você vai encontrar a solução. Este problema existe desde quando foi inventado o emulador de rag

Share this post


Link to post
Share on other sites
  • 0

@Jonyll Faz uma caridade, a gente já pesquisou e não achou nada relacionado.... só um do spell master mas ele não compartilhou os arquivos, ajuda nós !!

Share this post


Link to post
Share on other sites
  • 0

Erro no clientinfo ou de packet do emulador não alinhado com client. Boa sorte.

Share this post


Link to post
Share on other sites
  • 0

Agora entendo pq falam que o cronus ta perdido... puffz..

Share this post


Link to post
Share on other sites
  • 0

complicado =/ 
se eu soube-se desse erro até ajudaria  eu optei em usar old
tenta mudar hexed p/ ver se funciona... cronus não existe suporte + forum.  Comunidade agora é só p/ bate papo  msm 

Share this post


Link to post
Share on other sites
  • 0

Não é packet, e não é clientinfo.

O outro tópico referente à isso é MEU, e NÃO POSSUI A SOLUÇÃO.

Eu deixei claro que o erro está na Source do emulador. Também deixei o que eu fiz lá pra resolver, mas não pretendo compartilhar os arquivos por não ser uma solução definitiva/recomendável/certa, e nem tenho a permissão para tal.

Simplesmente estou usando uma versão da source antiga, pois os "desenvolvedores" do emulador fizeram mudanças na source dentro dos últimos ~8 meses e junto inseriram o problema. (não me perguntem porque não voltam ao estado estável anterior)

Ao mesmo tempo não admitem que o problema está no emulador, com todo teste possível que você faça ;) Quer provar? É só baixar o emulador virgem do git, compilar com qualquer versão de hexed e abrir. O bug não está só no chat de grupo como também nas PMs (só quem recebe visualiza o bug)

 

Outro exemplo é o desse tópico, que nem havia visto que fecharam e preciso reabrir:

Não cheguei a ver a última resposta, mas também não devem ter testado por si mesmo pois teriam descoberto o problema

O bug é do emulador. E continua com o mesmo problema 1 ano depois.

 

Estes erros são bem mais complexos do que parece, pelo menos pra alguém que não faz parte do desenvolvimento do emulador. Então ou todo mundo vem aqui e prova que o problema está na Source pra ver se tomam alguma atitude, ou eu sugiro mesmo que utilizem outro emulador, infelizmente.

Vendo pelo que o próprio Administrador do fórum disse ali em cima... "Boa sorte".

Share this post


Link to post
Share on other sites
  • 0
11 minutos atrás, AmyH disse:

Não é packet, e não é clientinfo.

O outro tópico referente à isso é MEU, e NÃO POSSUI A SOLUÇÃO.

Eu deixei claro que o erro está na Source do emulador. Também deixei o que eu fiz lá pra resolver, mas não pretendo compartilhar os arquivos por não ser uma solução definitiva/recomendável/certa, e nem tenho a permissão para tal.

Simplesmente estou usando uma versão da source antiga, pois os "desenvolvedores" do emulador fizeram mudanças na source dentro dos últimos ~8 meses e junto inseriram o problema. (não me perguntem porque não voltam ao estado estável anterior)

Ao mesmo tempo não admitem que o problema está no emulador, com todo teste possível que você faça ;) Quer provar? É só baixar o emulador virgem do git, compilar com qualquer versão de hexed e abrir. O bug não está só no chat de grupo como também nas PMs (só quem recebe visualiza o bug)

 

Outro exemplo é o desse tópico, que nem havia visto que fecharam e preciso reabrir:

Não cheguei a ver a última resposta, mas também não devem ter testado por si mesmo pois teriam descoberto o problema

O bug é do emulador. E continua com o mesmo problema 1 ano depois.

 

Estes erros são bem mais complexos do que parece, pelo menos pra alguém que não faz parte do desenvolvimento do emulador. Então ou todo mundo vem aqui e prova que o problema está na Source pra ver se tomam alguma atitude, ou eu sugiro mesmo que utilizem outro emulador, infelizmente.

Vendo pelo que o próprio Administrador do fórum disse ali em cima... "Boa sorte".

pois é =/ 
complicado ver isso do próprio Administrador, se ele que é quem é falou isso imagina o resto da equipe se é que ainda existe uma..

Share this post


Link to post
Share on other sites
  • 0
2 horas atrás, SoulEat disse:

pois é =/ 
complicado ver isso do próprio Administrador, se ele que é quem é falou isso imagina o resto da equipe se é que ainda existe uma..

Equipe, isso aqui ta abandona faz tempo, nego pede suporte, só aparece um fantasma, não existe, mais equipe, e em breve não existira mais cronus !

 

2 horas atrás, AmyH disse:

Não é packet, e não é clientinfo.

O outro tópico referente à isso é MEU, e NÃO POSSUI A SOLUÇÃO.

Eu deixei claro que o erro está na Source do emulador. Também deixei o que eu fiz lá pra resolver, mas não pretendo compartilhar os arquivos por não ser uma solução definitiva/recomendável/certa, e nem tenho a permissão para tal.

Simplesmente estou usando uma versão da source antiga, pois os "desenvolvedores" do emulador fizeram mudanças na source dentro dos últimos ~8 meses e junto inseriram o problema. (não me perguntem porque não voltam ao estado estável anterior)

Ao mesmo tempo não admitem que o problema está no emulador, com todo teste possível que você faça ;) Quer provar? É só baixar o emulador virgem do git, compilar com qualquer versão de hexed e abrir. O bug não está só no chat de grupo como também nas PMs (só quem recebe visualiza o bug)

 

Outro exemplo é o desse tópico, que nem havia visto que fecharam e preciso reabrir:

Não cheguei a ver a última resposta, mas também não devem ter testado por si mesmo pois teriam descoberto o problema

O bug é do emulador. E continua com o mesmo problema 1 ano depois.

 

Estes erros são bem mais complexos do que parece, pelo menos pra alguém que não faz parte do desenvolvimento do emulador. Então ou todo mundo vem aqui e prova que o problema está na Source pra ver se tomam alguma atitude, ou eu sugiro mesmo que utilizem outro emulador, infelizmente.

Vendo pelo que o próprio Administrador do fórum disse ali em cima... "Boa sorte".

Acho que vc deixou o teu post errado !

Share this post


Link to post
Share on other sites
  • 0
5 minutos atrás, iLovex disse:

Equipe, isso aqui ta abandona faz tempo, nego pede suporte, só aparece um fantasma, não existe, mais equipe, e em breve não existira mais cronus !

 

Acho que vc deixou o teu post errado !

Releia meu caro. Eu deixei um EXEMPLO de outro post na mesma situação.

Share this post


Link to post
Share on other sites
  • 0
1 hora atrás, AmyH disse:

Releia meu caro. Eu deixei um EXEMPLO de outro post na mesma situação.

Desculpa, mal interpretação minha, só queria uma solução para o meu problema...

Share this post


Link to post
Share on other sites
  • 0

é triste, dentro desses bugs o principal não são esses mais sim do nada o Emperium fica inquebravel e toda source não responde mais a guerra de emperium...

eu fiz uma coisa tive que ir no hercules e substituir as SRC e concertar o error pra resolver  o bug.

esse do chat ainda não tem solução por ser um erro de especialistas do  mesmo.

e triste ver a comunidade perdendo força. Mais vamos levantar ! ainda tem muito conteúdo bom aqui !

Share this post


Link to post
Share on other sites
  • 0

Já consegui resolver meu problema, não graças a esse péssimo suporte, mas fuçando na src eu consegui me virar. Pode fechar esse tópico que não me resolveu de nada.

Share this post


Link to post
Share on other sites
  • 0

Cronus já foi melhor !

Share this post


Link to post
Share on other sites
  • 0
11 horas atrás, WarPRO disse:

é triste, dentro desses bugs o principal não são esses mais sim do nada o Emperium fica inquebravel e toda source não responde mais a guerra de emperium...

eu fiz uma coisa tive que ir no hercules e substituir as SRC e concertar o error pra resolver  o bug.

esse do chat ainda não tem solução por ser um erro de especialistas do  mesmo.

e triste ver a comunidade perdendo força. Mais vamos levantar ! ainda tem muito conteúdo bom aqui !

Felizmente ainda não me deparei com isso. Mas é bom deixar o report pra ver se arrumam no Repositório Oficial.

Se deixar o emulador riginal desse jeito, realmente nunca terão novos programadores pra ajudar a comunidade.

Esse ainda é de longe o emulador com mais traduções disponíveis pro pessoal, e há um tempo atrás tinha mais gente dando suporte do que nos outros fóruns também.

Share this post


Link to post
Share on other sites
  • 0
34 minutos atrás, AmyH disse:

Felizmente ainda não me deparei com isso. Mas é bom deixar o report pra ver se arrumam no Repositório Oficial.

Se deixar o emulador riginal desse jeito, realmente nunca terão novos programadores pra ajudar a comunidade.

Esse ainda é de longe o emulador com mais traduções disponíveis pro pessoal, e há um tempo atrás tinha mais gente dando suporte do que nos outros fóruns também.

Pois é. Os tempos são outros. Sdds do Spell Master dando suporte. O cara conhece muito!

Share this post


Link to post
Share on other sites
  • 0

Mesmo assim, essa comunidade não pode morrer, bugs como esse não é muito dificil de reparar se tratando dos criadores. mais em fim eu vou torcer para que a comunidade volte...

Share this post


Link to post
Share on other sites
  • 0

O emulador do Cronus foi descontinuado, logo não vão encontrar solução para este problema.. só se vocês estudarem e arrumarem os bugs por conta própria.. minha sugestão.. usem o rAthena.. :confiante:

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Putz minha caixa de entrada de e-mail tava atordoada de mail pedindo essa correção.

Pra deixar claro eu não frequento mais o cronus, porém fiz a correção e postei na área de download, é só aguardar o @Jonyll liberar.

Até nunca mais... Assim eu espero.

Abrssssss....

Share this post


Link to post
Share on other sites
  • 0
Em 17/04/2018 at 09:07, SoulEat disse:

complicado ver isso do próprio Administrador, se ele que é quem é falou isso imagina o resto da equipe se é que ainda existe uma..

Não tem resto de equipe. O Cronus não tem equipe(e usuários reais, de bem, que não pensam no próprio umbigo/servidor) a sei lá quantos anos, muitos anos.

Em 17/04/2018 at 11:16, iLovex disse:

Equipe, isso aqui ta abandona faz tempo, nego pede suporte, só aparece um fantasma, não existe, mais equipe, e em breve não existira mais cronus !

É provável que não apareça mesmo. Sabe de quem é a culpa? Lembrando que ao apontar o dedo, terá 4 apontados para sí próprio.

Em 17/04/2018 at 13:20, iLovex disse:

Desculpa, mal interpretação minha, só queria uma solução para o meu problema...

Aqui um exemplo de como a comunidade funciona a anos e é por isso que esta assim atualmente e é por isso que o fim esta chegando.

Em 17/04/2018 at 22:36, WarPRO disse:

ainda tem muito conteúdo bom aqui !

É só isso que 99% da comunidade quer. Mas o conteúdo é velho, vocês vão renovar? Não, pois o que tem é o suficiente.

Em 18/04/2018 at 06:39, Felipe Arruda disse:

Já consegui resolver meu problema, não graças a esse péssimo suporte, mas fuçando na src eu consegui me virar. Pode fechar esse tópico que não me resolveu de nada.

Outro péssimo exemplo de modo geral. A pessoa aprendeu a resolver o seu problema, a comunidade agora não presta para nada, some de novo do fórum e volta com o rabo entre as pernas quando precisar de ajuda novamente.

O pior? Resolveu e não compartilhou a solução ou melhor, o caminho para as pessoas APRENDEREM  resolver seus problemas. Eu sempre, desde quando entrei no cronus, aprendi a quebrar a cabeça e resolver as coisas, ai vinha aqui ensinar(o que é diferente de simplesmente dar) o porque do erro e como é possível resolve-lo.

23 horas atrás, iLovex disse:

Cronus já foi melhor !

Verdade, a pelo menos uns 10 anos atrás(talvez mais). A comunidade toda era melhor.

22 horas atrás, AmyH disse:

Esse ainda é de longe o emulador com mais traduções disponíveis pro pessoal, e há um tempo atrás tinha mais gente dando suporte do que nos outros fóruns também.

o repositório esta lá, só fazer a tradução e compartilhar. .... espera, compartilhar é algo bem difícil não?

21 horas atrás, Felipe Arruda disse:

Pois é. Os tempos são outros. Sdds do Spell Master dando suporte. O cara conhece muito!

A maioria aqui(incluindo claro, você) tem saudades mesmo de quem simplesmente da a solução.

18 horas atrás, WarPRO disse:

Mesmo assim, essa comunidade não pode morrer, bugs como esse não é muito dificil de reparar se tratando dos criadores. mais em fim eu vou torcer para que a comunidade volte...

Se depender de vocês com um post/chat como este. Não voltará.

9 horas atrás, KyukE disse:

O emulador do Cronus foi descontinuado, logo não vão encontrar solução para este problema.. só se vocês estudarem e arrumarem os bugs por conta própria.. minha sugestão.. usem o rAthena.. :confiante:

correto. Mas pessoalmente prefiro uma mescla de Herc+rA, são gostos.

3 horas atrás, Spell Master disse:

Putz minha caixa de entrada de e-mail tava atordoada de mail pedindo essa correção.

Pra deixar claro eu não frequento mais o cronus, porém fiz a correção e postei na área de download, é só aguardar o @Jonyll liberar.

Até nunca mais... Assim eu espero.

Abrssssss....

Vou pensar se libero, eles aqui do chat e a comunidade não merece.

Sobre o restante do post, sobre o post em sí, segue:

v8xdcr.jpg

@Spell Master

Não irei aprovar seu envio pois ele consta a 'solução' pronta. Faça um guia(se estiver disposto claro) do porque deste erro, onde constam estes erros e como resolve-los em seus devidos locais.

Obrigado.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

Seja bem vindo ao Cronus-Emulator.
É sempre um prazer te-lo conosco.
Você pode visualizar nossas áreas de suporte para encontrar suas soluções sem a necessidade de se registrar!
Registrando em nossa comunidade, você poderá conhecer mais sobre nosso projeto, criar tópicos, responder tópicos existentes, baixar milhares de recursos em nosso sistema de downloads, participar de nossa comunidade, customizar seu perfil e muito mais... Se você já possui uma conta, faça seu login - ou crie uma conta. Também temos integração com Google+ e Facebook.

×
×
  • Create New...