Jump to content
  • 0
Sign in to follow this  
ragmaniaco

[Resolvido] Muitas duvidas sobre customização

Question

Já de ante-mão peço desculpas pela quantidade de perguntas, fiquei sem internet por uns tempos mas não parei de "mecher" com ragnarok...

pessoal, coloquei uns custons novos no meu client pra testar, configurei tds os arquivos corretamente, tanto que quando dou botão direito do mouse a descrição e a splash art é exibida, o icone no inventario é exibido, ao dropar o item ele é exibido, porem ao equipar ou após equipar se olhar no inventario ou mesmo na hora de logar o game pede por uma sprite com um nome nada a ver com o nome da sprite do meu item, e meu lua file ta configurado corretamente.

tanto esta corretamente configurado que quando vou testar por um programa esterno o custom aparece e funciona, ja in-game da esse bug.

xTCuegV.png

6UGrSs9.png

0JXlxQS.png

 

- - - - - -

DUVIDA

gostaria de criar alguns custons eu mesmo, mas não faço ideia de que programa utilizar para criar as sprites dos custons.

criei um custom sem efeito visual [item consumivel] e gostaria de adicionar efeito no item, quando utilizar alterar a aparencia do personagem para a classe 25, mas sem alterar o job do char para que o mesmo possa continuar acessando suas skills normalmente.

fiz outros custons que não necessita de sprite, equipamentos dessa vez, gostaria de colocar alguns efeitos mas não sei como colocar, no caso seria aumentar a capacidade de carga sem aumentar a STR e sem adicionar skill ao personagem, deixar o personagem imune a habilidades que empurram e +5% de dano a propriedade neutra a cada level de refinamento.

com relação ao refinamento, ja tentei configurar a db de exp de refinamento, mas não consigo fazer passar de +10, como posso alterar o level maximo de refinamento dos itens ???

quais são os arquivos BMP que os mapas GUILD_VS3 e GUILD_VS2 utilizam ?

estou configurando um combo de itens que ao equipar todos os itens do combo o char ganha habilidades, na "aparencia" antiga do RAGNAROK onde a janela de habilidades era unica com scroll caberia todas as skills, mas com essa nova janela, acredito que não vá caber todas as skills que o char receberia, como posso resolver isso ? é possivel aumentar a quantidade de habilidades listadas em cada guia dessa nova "aparencia" da janela de habilidades ? como ?

existe algum tutorial bem completo aqui no forum sobre como criar mapas e mobs ? a parte dos mobs eu gostaria de aprender a criar a sprite dos mobs e utilizar as sprites que eu criar ao invez de customizar sprites existentes com o sistema do mob_avail do emulador.

Edited by ragmaniaco
Prints adicionadas

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Referente ao erro, baixe o arquivo que eu coloquei em anexo e coloque no diretório: data/texture/À¯ÀúÀÎÅÍÆäÀ̽º

Segundo, basicamente todas essas personalizações você encontra informações aqui: http://herc.ws/wiki/Main_Page

 

compare.rar

Share this post


Link to post
Share on other sites
  • 0
8 horas atrás, Pixel disse:

Referente ao erro, baixe o arquivo que eu coloquei em anexo e coloque no diretório: data/texture/À¯ÀúÀÎÅÍÆäÀ̽º

Segundo, basicamente todas essas personalizações você encontra informações aqui: http://herc.ws/wiki/Main_Page

 

compare.rar

ué, man, esses arquivos não são apenas a parte visual do client ? eu acredito ja ter todos esses arquivos, mas de qualquer forma vou testar aqui.

vou ler tambem o link, obrigado pela ajuda, qualquer coisa dou um edit aqui.

@edit

ainda não sei o nome dos .bmp que os maps guild_vs2 e guild_vs3 usam, e tambem sobre os efeitos dos itens, ainda não sei qual codigo seria referente para cada efeito que procuro e tambem não sei como alterar a "aparencia" do char sem ter que alterar sua job, no link não tem essas informações

Edited by ragmaniaco

Share this post


Link to post
Share on other sites
  • 0

@ragmaniaco olha, quando você cria custom item assim, e ele é visual, visual que eu digo é algo que tem que aparecer, tipo um hat... Uma asa... Então, esse item precisa ter o próprio VIEW ID... Na aba da criação do item no item_db é importante que você coloque no script o view ID referente ao view ID que você registrou nos arquivos .lub/lua, caso tenha dúvida e curiosidade, olha o script e outros hats pra você ver que eles tem no script, uma linha chamada view ID.

Bom, vamos lá... Caminho na pasta data para adicionar o seu view ID que vai ler o item nos arquivos lub/lua:

luafiles514/luafiles/datainfo/acessoryid.lub

 

Entre o script do desse doc .lub adicione 

Quote

 ACCESSORY_Nome_do_item = ViewID,

Não esqueça das vírgulas corretas e dos códigos usados pra fechamento do script, pois muitos não sabem, mas os arquivos .lua/lub são arquivos como se fossem scripts, não é um .txt qualquer, existem regras de edição pra esses documentos, portanto não escreva nada fora da leitura do código, se não vai dar erro quando abrir o Hexed. Recomendo utilizar um ViewID um pouco distante pra não correr o risco de usar um já existente, se não, o que acontecerá é tipo, você equipar um poring hat e vestir um óculos, view ids trocados...

Não sei se conseguiu entender, dei um norte! E tenho quase certeza que o problema é esse...

Abraços

  • Love 1

Share this post


Link to post
Share on other sites
  • 0
14 minutos atrás, Dakt disse:

@ragmaniaco olha, quando você cria custom item assim, e ele é visual, visual que eu digo é algo que tem que aparecer, tipo um hat... Uma asa... Então, esse item precisa ter o próprio VIEW ID... Na aba da criação do item no item_db é importante que você coloque no script o view ID referente ao view ID que você registrou nos arquivos .lub/lua, caso tenha dúvida e curiosidade, olha o script e outros hats pra você ver que eles tem no script, uma linha chamada view ID.

Bom, vamos lá... Caminho na pasta data para adicionar o seu view ID que vai ler o item nos arquivos lub/lua:

luafiles514/luafiles/datainfo/acessoryid.lub

 

Entre o script do desse doc .lub adicione 

Não esqueça das vírgulas corretas e dos códigos usados pra fechamento do script, pois muitos não sabem, mas os arquivos .lua/lub são arquivos como se fossem scripts, não é um .txt qualquer, existem regras de edição pra esses documentos, portanto não escreva nada fora da leitura do código, se não vai dar erro quando abrir o Hexed. Recomendo utilizar um ViewID um pouco distante pra não correr o risco de usar um já existente, se não, o que acontecerá é tipo, você equipar um poring hat e vestir um óculos, view ids trocados...

Não sei se conseguiu entender, dei um norte! E tenho quase certeza que o problema é esse...

Abraços

muito obrigado pela dica, mas acabei aprendendo isso na marra enquanto mechia com isso e estava sem internet, os lub/lua files estao corretos referente aos view ids, e so olhar nas prints que adicionei ao topico, estão cadastrados corretamente, tanto nos lubs quanto no item db 2 e mesmo assim esse gravity persiste.

ainda nao testei os arquivos bmp que o pixel postou como resposta pois estou para formatar o pc, mas assim que possivel vou testar e postar a resposta aqui do resultado

Share this post


Link to post
Share on other sites
  • 0

@Pixel após a alteração com os arquivos que você me enviou, agora recebo este erro http://prntscr.com/grhtrt

@EDIT 

Agora que tenho um pc com net da pra colocar as coisas mais facil

meus arquivos como estão

DATA\SPRITE\¾Ç¼¼»ç¸®\³²

³²_Purple_Wandering_Wolf_Hat.spr / ³²_Purple_Wandering_Wolf_Hat.act

DATA/LUA FILES/DATAINFO/ACCNAME.LUA

    [ACCESSORY_IDs.ACCESSORY_Purple_Wandering_Wolf_Hat] = "_Purple_Wandering_Wolf_Hat",

DATA/LUA FILES/DATAINFO/ACCESSORYID.LUA

    ACCESSORY_Purple_Wandering_Wolf_Hat = 2491,

DB/ITEM_DB2.CONF

{
    Id: 21492
    AegisName: "Purple_Wandering_Wolf_Hat"
    Name: "Purple_Wandering_Wolf_Hat"
    Type: 5
    Buy: 0
    Weight: 20
    Slots: 4
    Loc: 256
    WeaponLv: 1
    EquipLv: 1
    View: 2491
},
Edited by ragmaniaco
os spoilers bugaram .-.

Share this post


Link to post
Share on other sites
  • 0

Qual a data do seu client ? dependendo ele só pega VIEW até 2000, se for esse o caso você deve trocar a VIEW para abaixo de 2000, se não não vai funcionar.

  • Love 1

Share this post


Link to post
Share on other sites
  • 0
13 horas atrás, Pixel disse:

Qual a data do seu client ? dependendo ele só pega VIEW até 2000, se for esse o caso você deve trocar a VIEW para abaixo de 2000, se não não vai funcionar.

não sabia que tinha dessas tbm, vou testar aqui, pegar um item da view 1999 depois 2000 e em seguida 2001 pra ver se vai dar crash.

minha data é baseada na data com os custons que o mihael postou aqui no forum, mas fiz umas modificações adicionando mais itens, entretando não utilizo o hexed dele que só me deu dor de cabeça, utilizo um hexed 2010 07 30 RE

@EDIT

@Pixel consegui equipar um item de View 3007, porem ele não é visual, e apenas um manteu

ja o item evil poring hat da crash ao equipar, e ele é justamente a View 2000.

como posso resolver isso ? meus itens começão no View ID 2000 -.-'

OBS : antes de criar esse tópico, eu já havia tentado definir para ids abaixo de 2000 e dava conflito, pois quando eu equipava um item aparecia a sprite de outro item, porem esse outro item era da DB Main, ou seja, um item original do game, e se não me falha a memoria a View era 14xx.

Edited by ragmaniaco

Share this post


Link to post
Share on other sites
  • 0

Verifique o erro que apresenta quando você tenta compilar, ou pegue o arquivo .lua e salve em formato .lub

Share this post


Link to post
Share on other sites
  • 0
4 horas atrás, Pixel disse:

Verifique o erro que apresenta quando você tenta compilar, ou pegue o arquivo .lua e salve em formato .lub

então @Pixel o erro eu vejo, mas não faz sentido o erro que exibe para mim

http://prntscr.com/gssihd

em um é exibido erro referente aos colchetes, porem existem apenas o de abertura e encerramento do código, nada a mais, e no outro exibe um caractere que não tem no arquivo ué

Share this post


Link to post
Share on other sites
  • 0

Na verdade, o erro é bem simples, olhe na linha que acusa o erro, no caso a 1560:

ACCESSORY_Megingjard_da_força = 2363,

Não pode ter acentuação, troque para:

ACCESSORY_Megingjard_da_forca = 2363,

Share this post


Link to post
Share on other sites
  • 0
2 horas atrás, Pixel disse:

Na verdade, o erro é bem simples, olhe na linha que acusa o erro, no caso a 1560:

ACCESSORY_Megingjard_da_força = 2363,

Não pode ter acentuação, troque para:

ACCESSORY_Megingjard_da_forca = 2363,

@Pixel na vdd n man, antes de responder com as prints dos erros tentei trocar o cedilha por c comum, porem os erros persistem nos dois arquivos,após ver que persistem voltei para o cedilha achando que não havia problema em deixa-los lá, então alem do problema que eu desconheço nos arquivos, ainda tem o cedilha, vou procurar os nomes acentuados e altera-los, se n for pedir mt, poderia verificar novamente os dois arquivos e ver se tem algum erro fora esse por favor ? assim que terminar de verificar os caracteres com acentuação torno a responder aqui, desde já obrigado pela força

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

Seja bem vindo ao Cronus-Emulator.
É sempre um prazer te-lo conosco.
Você pode visualizar nossas áreas de suporte para encontrar suas soluções sem a necessidade de se registrar!
Registrando em nossa comunidade, você poderá conhecer mais sobre nosso projeto, criar tópicos, responder tópicos existentes, baixar milhares de recursos em nosso sistema de downloads, participar de nossa comunidade, customizar seu perfil e muito mais... Se você já possui uma conta, faça seu login - ou crie uma conta. Também temos integração com Google+ e Facebook.

×
×
  • Create New...