Jump to content
  • 0
Sign in to follow this  
Aleaf

Servidor nem conecta pela RLCP

Question

Olá, gente.

Estou utilizando o plano de host da virtuaTI, que pussui ftp e rlcp. configurei meu emulador, compilei, liguei o servidor... porém, ele nem ao menos conecta direito... está fechado, mesmo o rlcp dizendo que está online.

Alguém conhece as configurações que devem ser feitas? já tentei até mudar os ip's pro ip do host ao invés de deixar no padrão local (127.0.0.1)

Agradeceria muito se alguém pudesse me ajudar.

dados do login-server (log do emulador)

[info]: Cronus Versao:8.1.65
[Warning]: You are running Hercules with root privileges, it is not necessary.
[info]: Server supports up to '1024' concurrent connections.
[info]: Finished reading conf/import/inter_conf.txt.
[info]: Finished reading conf/inter-server.conf.
[status]: Login server binding IP address : 208.115.219.58 -> 208.115.219.58
[info]: Finished reading conf/import/login_conf.txt.
[info]: Finished reading conf/login-server.conf.
[status]: The login-server is ready (Server is listening on the port 7372).
[info]: Connection request of the char-server 'TheSevenRo' @ 208.115.219.58:2517 (account: 's1', pass: 'p1', ip: '208.115.219.58')
[Notice]: Authentication accepted (account: s1, id: 1, ip: 208.115.219.58)
[status]: Connection of the char-server 'TheSevenRo' accepted.
[info]: Closed connection from '216.245.206.42'.

O log do char-server, está ok

e do map-server, está assim:

[status]: Event 'OnInit' executed with '1477' NPCs.

[status]: Server is 'ready' and listening on port '4492'.
[status]: Attempting to connect to Char Server. Please wait.
[status]: Connecting to 208.115.219.58:2517
[status]: Logging in to char server...
[status]: Successfully logged on to Char Server (Connection: '6').
[status]: Sending maps to char server...
[status]: Event 'OnInterIfInit' executed with '0' NPCs.
[status]: Event 'OnInterIfInitOnce' executed with '0' NPCs.
[status]: Requested '34' guild castles from char-server...
[status]: Map Server is now online.
[info]: Received Fame List of '0' characters.
[status]: Received '34' guild castles from char-server.
[info]: Closed connection from '216.245.206.42'.
[info]: Closed connection from '216.245.206.42'.

O RLCP me dá a opção de resetar o inter_athena.conf, porém, não entendo muito bem... comecei há alguns dias...

Edited by Aleaf

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Meu caro, peça suporte a o host que lhe revendeu o produto com painel custom, provavelmente só eles podem lhe dizer o que vem a ocorrer.

  • Love 2

Share this post


Link to post
Share on other sites
  • 0

Qual mensagem aparece quando você deseja logar?

"Recusado pelo Servidor"

"Servidor Fechado"

"Não foi possível conectar ao servidor"

Vejo pelo seu Log que a porta de conexão está diferente da convencional. Você realizou a alteração no Clientinfo.xml?

Edited by xChiron
  • Love 1

Share this post


Link to post
Share on other sites
  • 0

Qual mensagem aparece quando você deseja logar?

"Recusado pelo Servidor"

"Servidor Fechado"

"Não foi possível conectar ao servidor"

Vejo pelo seu Log que a porta de conexão está diferente da convencional. Você realizou a alteração no Clientinfo.xml?

@xChiron

"não foi possivel conectar ao servidor"

a porta está diferente, pois no rlcp, eles dão essas portas ao informar dos dados do emulador.

@edit

Se for o caso, podem me indicar um host que raramente dê problemas como esse?

Edited by Aleaf

Share this post


Link to post
Share on other sites
  • 0

@xChiron

"não foi possivel conectar ao servidor"

a porta está diferente, pois no rlcp, eles dão essas portas ao informar dos dados do emulador.

@edit

Se for o caso, podem me indicar um host que raramente dê problemas como esse?

O problema não é o host amigo, mas sim a configuração.

No seu outro tópico, você informou o clientinfo usando a porta 6900 para conexão, porém você usa 7372.

[status]: The login-server is ready (Server is listening on the port 7372).

Você fez esta alteração no seu clientinfo.xml?

Edited by xChiron
  • Love 1

Share this post


Link to post
Share on other sites
  • 0

O problema não é o host amigo, mas sim a configuração.

No seu outro tópico, você informou o clientinfo usando a porta 6900 para conexão, porém você usa 7372.

[status]: The login-server is ready (Server is listening on the port 7372).

Você fez esta alteração no seu clientinfo.xml?

@xChiron

Fiz, pois o host informou estes dados no rlcp para mim. Vou reconfigurar para as portas padrão e posto aqui.

Edited by Aleaf

Share this post


Link to post
Share on other sites
  • 0

Mesma coisa.

clientinfo

<?xml version="1.0" encoding="euc-kr" ?>

<clientinfo>
<desc>Ragnarok Client Information - Taiwan Version</desc>
<servicetype>korea</servicetype>
<servertype>sakray</servertype>
<connection>
<display>The Seven Ro</display>
<desc>Um mundo de novas descobertas</desc>
<balloon>Divirtam-se</balloon>
<address>208.115.219.58</address>
<port>6900</port>
<version>25</version>
<langtype>8</langtype>
<aid>
<admin>2000000</admin>
<admin>2000001</admin>
<admin>2000002</admin>
</aid>
<loading>
<image>loading00.jpg</image>
<image>loading01.jpg</image>
<image>loading02.jpg</image>
<image>loading03.jpg</image>
</loading>
</connection>
<registrationweb>http://thesevenro.virtuati.com.br/</registrationweb>
</clientinfo>

Login-server

// O login-server reconhece a interface com este endereço de IP.

// NOTA: Isto permite rodar vários servidores em múltiplas interfaces
// usando a mesma porta para cada servidor.
//bind_ip: 127.0.0.1
// Porta do Login-Server
login_port: 6900

map-server

// IP do Char-Server
// O map-server conecta-se ao char-server usando este endereço de IP.
// NOTA: é útil quando seu servidor está sendo rodado com um firewall ou
// em uma máquina com múltiplas interfaces.
char_ip: 127.0.0.1
// O map-server reconhece a interface com este endereço de IP.
// NOTA: Isto permite rodar vários servidores em múltiplas interfaces
// usando a mesma porta para cada servidor.
//bind_ip: 127.0.0.1
// Porta do Char-Server
char_port: 6121
// IP do Map-Server
// O endereço de IP cujo o client irá usar para se conectar.
// Defina isto para seu IP público do servidor.
map_ip: 127.0.0.1
// Porta do Map-Server
map_port: 5121

char-server

//IP do Login-Server
//O char-server conecta-se ao login-server usando este endereço de IP.
//NOTA: É útil quando seu servidor está sendo rodado com um firewall ou
//em uma máquina com múltiplas interfaces.
login_ip: 127.0.0.1
//O char-server reconhece a interface com este endereço de IP.
//NOTA: Isto permite rodar vários servidores em múltiplas interfaces
//usando a mesma porta para cada servidor.
//bind_ip: 127.0.0.1
//Porta do Login-Server
login_port: 6900
//Character Server IP
//O endereço de IP cujo o client irá usar para se conectar.
//Defina isto para seu IP público do servidor.
char_ip: 127.0.0.1
//Porta do Char-Server
char_port: 6121

Login_conf

bind_ip: 208.115.219.58

login_port: 7372

Dados fornecidos pelo host

Informações do Emulador

IP de conexão: 208.115.219.58 ( us.png )
Porta LOGIN-SERVER: 7372
Porta CHAR-SERVER: 2517
Porta MAP-SERVER: 4492

bem é isso...@xChiron

Não consegui.

Edited by Aleaf

Share this post


Link to post
Share on other sites
  • 0

Olhe o MP que eu lhe enviei.

  • Love 1

Share this post


Link to post
Share on other sites
  • 0

Por padrão, o RLCP não permite a alteração das portas para diferentes das que foram selecionadas por você. Conforme também informada via ticket, o emulador está ligado e funcional, você deve verificar algo em seu patch que esteja causando estes problemas. O emulador ao ser ligado por estar em planos com RLCP, automaticamente já é configurado corretamente quanto à inter_athena, IPs e Portas.

Uma vez que você já informou no tópico, que o erro retornado é "não foi possivel conectar ao servidor", acontece quando o hexed não consegue conectar-se as configurações do client-side informadas em sua data. O IP e a Porta no clientinfo devem obrigatoriamente estarem configurados de forma correta, segundo seu clientinfo, você está utilizando a porta 6900, esta não é sua porta de login-server.

Meu caro, peça suporte a o host que lhe revendeu o produto com painel custom, provavelmente só eles podem lhe dizer o que vem a ocorrer.

Esta é uma informação completamente incorreta. Independente de haver um painel custom ou não, a responsabilidade pela aplicação estar funcionando ou não é única do usuário que pretende usá-la (vide GNU GPL) e em caso de ajuda, ele deve buscar junto aos desenvolvedores, ou seja, no caso do Cronus, aqui conosco.

Share this post


Link to post
Share on other sites
  • 0

Aconteceu a mesma coisa comigo, porém não me atentei as portas, enfim de qualquer maneira o seu clientinfo deve ficar assim:

<?xml version="1.0" encoding="euc-kr" ?>

<clientinfo>
<desc>Ragnarok Client Information - Taiwan Version</desc>
<servicetype>korea</servicetype>
<servertype>sakray</servertype>
<connection>
<display>The Seven Ro</display>
<desc>Um mundo de novas descobertas</desc>
<balloon>Divirtam-se</balloon>
<address>208.115.219.58</address>
<port>7372</port>
<version>25</version>
<langtype>8</langtype>
<aid>
<admin>2000000</admin>
<admin>2000001</admin>
<admin>2000002</admin>
</aid>
<loading>
<image>loading00.jpg</image>
<image>loading01.jpg</image>
<image>loading02.jpg</image>
<image>loading03.jpg</image>
</loading>
</connection>
<registrationweb>http://thesevenro.virtuati.com.br/</registrationweb>
</clientinfo>

Share this post


Link to post
Share on other sites
  • 0

Consegui logar, porém, depois que seleciono o personagem...recebo "não foi possível conectar-se ao servidor"

aqui estão meus arquivos:
ClientInfo.xml

<?xml version="1.0" encoding="euc-kr" ?>

<clientinfo>
<desc>Ragnarok Client Information - Taiwan Version</desc>
<servicetype>korea</servicetype>
<servertype>sakray</servertype>
<connection>
<display>The Seven Ro</display>
<desc>Um mundo de novas descobertas</desc>
<balloon>Divirtam-se</balloon>
<address>208.115.219.58</address>
<port>7372</port>
<version>25</version>
<langtype>8</langtype>
<aid>
<admin>2000000</admin>
<admin>2000001</admin>
<admin>2000002</admin>
</aid>
<loading>
<image>loading00.jpg</image>
<image>loading01.jpg</image>
<image>loading02.jpg</image>
<image>loading03.jpg</image>
</loading>
</connection>
<registrationweb>http://thesevenro.virtuati.com.br/</registrationweb>
</clientinfo>

char-server:

//IP do Login-Server

//O char-server conecta-se ao login-server usando este endereço de IP.
//NOTA: É útil quando seu servidor está sendo rodado com um firewall ou
//em uma máquina com múltiplas interfaces.
login_ip: 127.0.0.1
//O char-server reconhece a interface com este endereço de IP.
//NOTA: Isto permite rodar vários servidores em múltiplas interfaces
//usando a mesma porta para cada servidor.
//bind_ip: 127.0.0.1
//Porta do Login-Server
login_port: 7372
//Character Server IP
//O endereço de IP cujo o client irá usar para se conectar.
//Defina isto para seu IP público do servidor.
char_ip: 208.115.219.58
//Porta do Char-Server
char_port: 2517

Login-server

// O login-server reconhece a interface com este endereço de IP.

// NOTA: Isto permite rodar vários servidores em múltiplas interfaces
// usando a mesma porta para cada servidor.
//bind_ip: 127.0.0.1
// Porta do Login-Server
login_port: 7372

map-server:

// IP do Char-Server

// O map-server conecta-se ao char-server usando este endereço de IP.
// NOTA: é útil quando seu servidor está sendo rodado com um firewall ou
// em uma máquina com múltiplas interfaces.
char_ip: 127.0.0.1
// O map-server reconhece a interface com este endereço de IP.
// NOTA: Isto permite rodar vários servidores em múltiplas interfaces
// usando a mesma porta para cada servidor.
//bind_ip: 127.0.0.1
// Porta do Char-Server
char_port: 2517
// IP do Map-Server
// O endereço de IP cujo o client irá usar para se conectar.
// Defina isto para seu IP público do servidor.
map_ip: 208.115.219.58
// Porta do Map-Server
map_port: 4492

essas configurações foram me passadas pelo @xChiron

A partir daí, consegui logar no servidor, mas sou desconectado depois que seleciono o char.

Share this post


Link to post
Share on other sites
  • 0

Qual é o retorno no map, login e char server? No momento em que faz a requisição de login, ele aceita porque consegue localizar a máquina, mas se no momento de selecionar o personagem dá erro, há algo de errado em suas configurações. É muito provável que o hexed que está definido em /src/common/mmo.h seja incompatível com o que esteja utilizando, por isso, ele não consegue trabalhar.

@Edit

Mais uma vez vale lembrar, não adianta você alterar IP, Bind IP e Porta no seu emulador, por estar no RLCP, ele fará a configuração toda vez que iniciar, para evitar problemas de má configuração.

Share this post


Link to post
Share on other sites
  • 0

Tenta utilizar o tutorial abaixo para alterar seu mmo.h de acordo com a data do seu hexed.

http://forum.cronus-emulator.com/tutorials/article/534-trocando-a-data-do-seu-emulador-para-a-data-do-seu-hexed/

Lembrando que depois de alterar o mmo.h e necessário recompilar o emulador.

Qualquer dúvida posta ai :D

Share this post


Link to post
Share on other sites
  • 0

Qual é o retorno no map, login e char server? No momento em que faz a requisição de login, ele aceita porque consegue localizar a máquina, mas se no momento de selecionar o personagem dá erro, há algo de errado em suas configurações. É muito provável que o hexed que está definido em /src/common/mmo.h seja incompatível com o que esteja utilizando, por isso, ele não consegue trabalhar.

@Edit

Mais uma vez vale lembrar, não adianta você alterar IP, Bind IP e Porta no seu emulador, por estar no RLCP, ele fará a configuração toda vez que iniciar, para evitar problemas de má configuração.

O Emulador foi compilado da forma correta com o ajuste no mmo.h.

Ele me forneceu acesso aos dados dele do RLCP e FTP , porém a conexão foi sem sucesso. Tentei todas as formas de subnet imagináveis pelo homem e nenhuma surte qualquer efeito...

Só para frisar, ao iniciar o emulador dele, aparece isso a cada 30 segundos:

[info]: Closed connection from 216.245.206.42

Whois

screenshot_868.png

DNS

screenshot_869.png

Edited by xChiron

Share this post


Link to post
Share on other sites
  • 0

Verifique os logs retornados do map, login e char-server. Ele retorna erros de conta desconhecida, senha incorreta e pacote desconhecido. Algum deles é, talvez até mesmo o emulador possa estar causando isto. Depende muito das demais configurações do emulador, fora o IP e os dados do MySQL.

Quanto ao IP que comentou, ele faz esta conexão a cada 60 segundos, exatamente, para puxar dados para os relatórios que o usuário tem acesso através do RLCP.

Share this post


Link to post
Share on other sites
  • 0

Verifique os logs retornados do map, login e char-server. Ele retorna erros de conta desconhecida, senha incorreta e pacote desconhecido. Algum deles é, talvez até mesmo o emulador possa estar causando isto. Depende muito das demais configurações do emulador, fora o IP e os dados do MySQL.

Quanto ao IP que comentou, ele faz esta conexão a cada 60 segundos, exatamente, para puxar dados para os relatórios que o usuário tem acesso através do RLCP.

O Emulador simplesmente não dá sinal plausível do motivo da rejeição. :o

Descarto quaisquer configurações de autenticação,pois o RLCP "faz tudo".

A Requisição do Login-Server é aceita

screenshot_871.png

O Char-server confirma a requisição e carrega as configurações de personagem. Após isso, chuta o nosso amigo sem dar explicações... Ta parecendo mulher isso :lol:

screenshot_870.png

Map-server sem a qualquer anormalidade quanto a autenticação:

screenshot_872.png

Edited by xChiron

Share this post


Link to post
Share on other sites
  • 0

Galerinha, Pode fechar o tópico. Mudei de host. agora é ssh, o rlcp não funcionou. Só tô tento trabalho agora com o hexed 20120410

Share this post


Link to post
Share on other sites
  • 0

@xChiron

Se o servidor está fechando a conexão, pode ser relativo ao hexed ou ao packet_db. Se é uma das versões finais do Cronus, não há mais necessidade de configuração do packet_db, então, só pode ser o hexed ou até mesmo lua files interferindo nos pacotes enviados.

Aviso automático:

Esse tópico foi fechado por um moderador.

Motivo: A pedido do autor

Se você não concorda com esta ação, vá até o Tribunal de Pequenas Causas.

Equipe Cronus Emulator.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

Seja bem vindo ao Cronus-Emulator.
É sempre um prazer te-lo conosco.
Você pode visualizar nossas áreas de suporte para encontrar suas soluções sem a necessidade de se registrar!
Registrando em nossa comunidade, você poderá conhecer mais sobre nosso projeto, criar tópicos, responder tópicos existentes, baixar milhares de recursos em nosso sistema de downloads, participar de nossa comunidade, customizar seu perfil e muito mais... Se você já possui uma conta, faça seu login - ou crie uma conta. Também temos integração com Google+ e Facebook.

×
×
  • Create New...